Search:

Werbung:

Google+:

Archiv:


Jens Matheuszik — 11. November 2007, 13:49 Uhr

Argh… ich hasse den Microsoft Internet Explorer


pottblog.deGestern musste durfte ich das Pottblog via Microsoft Internet Explorer mir anschauen:

Argh!

Eigentlich ging ich davon aus, dass das MS IE-Problem beim „neuen“ Layout des Pottblogs schon lange korrigiert sei, aber dem ist nicht so (gewesen):
Überlappende Texte, Grafiken die über dem Text abgebildet wurden, Aufzählungen deren Zahlen (1., 2. usw.) im kaum sichtbaren Bereich gezeigt wurden usw.usf.

Ich habe daraufhin ein wenig in der CSS-Datei (die das Layout bestimmt) und im eigentlichen Layouttheme verändert, so dass es jetzt einigermaßen klappen sollte. Auch wenn es mir nicht gefällt, dass Einzelbeiträge jetzt im eigentlich vorzuziehenden Browser Mozilla Firefox nicht mehr ganz so aussehen, wie ich mir das wünsche.

Solange aber noch mehr als die Hälfte der Pottblog-Benutzer den Microsoft Internet Explorer nutzt, sollte man da schon ein wenig auf die CSS-Macken des MS IE Rücksicht nehmen…

… und ganz entsetzt war ich gerade auf einer anderen Seite die ich vor kurzem ehrenamtlich gestaltet habe, deren WordPress-Theme mit meinen minimalen Änderungen so gänzlich inkompatibel zum Microsoft Internet Explorer ist.

Kein Wunder, dass ich auf das Layout noch keinerlei Rückmeldungen bekommen habe… da werde ich wohl mal was anderes ausprobieren.


18 Kommentare »

RSS-Feed für Kommentare zu diesem Artikel. TrackBack URI.

  1. (1) Kommentar by Silent @ 11. November 2007, 14:31 Uhr

    Hallo Jens,
    ich nehme da schon lange keine Rücksicht mehr auf den IE.
    Das Ding nervt einfach und wer meine Blogs nicht richtig lesen kann weil Darstellungsfehler im IE sind, hat halt einfach Pech gehabt.


  2. (2) Kommentar by Chikatze @ 11. November 2007, 16:29 Uhr

    Geht mir ganz genauso. Mein Blog ist mit dem IE eine Katastrophe. Geht mir aber ziemlich am A… vorbei! 😉


  3. (3) Kommentar by el-flojo @ 11. November 2007, 19:22 Uhr

    Bei mir sind’s nur Kleinigkeiten, die im Internet Explorer nicht laufen, aber ich mach mir da auch keinen Kopp drüber.
    Meiner Meinung nach, sollte man allen Leuten, die ausschließlich mit dem MSIE (am besten noch in Version 5!!) unterwegs sind, den Rechner wegnehmen.
    Die gefährden schlimmstenfalls noch andere. 😉


  4. (4) Kommentar by Chikatze @ 11. November 2007, 21:19 Uhr

    Bei Euch fühl‘ ich mich wohl!!! :) *räkel*


  5. (5) Kommentar by mkorsakov @ 11. November 2007, 21:35 Uhr

    Was viel interessanter ist: im aktuellen Opera (9.2.4, winxp sp2) erscheint auf der jeweiligen Artikelseite kein Artikel sondern nur die Kommentare …
    Im Benutzermodus (kwasi CSS ausgeschaltet) kann man den Beitrag dann wieder lesen.


  6. (6) Kommentar by Jens @ 11. November 2007, 21:39 Uhr

    @Silent, chikatze, el-flojo:
    Eigentlich sehe ich das ja auch wie ihr – aber wenn ich halt mitbekomme, dass ein Großteil (die Mehrheit) der Besucher die Inhalte nicht vernünftig sehen kann, dann will ich doch auch eingreifen.

    @mkorsakov:
    Argh! Was ist das denn für ein merkwürdiger Fehler? Leider habe ich gerade keinen Opera parat um das zu testen. Ich vermute aber, dass es an meinen aktuellen Änderungen (i.S. MS IE) liegt, denn eigentlich funktionierte es mit Opera immer ohne Probleme. Ich muss das die Tage noch mal anschauen.


  7. (7) Kommentar by Silent @ 11. November 2007, 23:03 Uhr

    @Jens
    Wenn man aber weiterhin den IE unterstützt und damit die Faulheit der User auf einen vernünftigen Browser zu wechseln, ändert sich nie was.
    Weder im Nutzungsverhalten der User, noch bei den Programmierern von Microsoft.
    Kann ja nicht angehen das ein paar Programmierer zu blöde sind ein vernünftiges Programm auf die Beine zu stellen und Millionen Webseitenbetreiber sollen das ausbügeln.
    Das ganze Problem hätte man nicht, wenn es MS verboten würde den IE überall bei seinem Betriebssystem einzubauen. Dann müssten sie sich wirklich dem Markt stellen und nicht auf Bequemlichkeit der User hoffen.


  8. (8) Kommentar by Chikatze @ 11. November 2007, 23:31 Uhr

    Also, bei mir ist das – Gott sei Dank! – nicht die Mehrheit der Leser! 😉


  9. (9) Kommentar by Silent @ 12. November 2007, 09:30 Uhr

    @Chikatze
    Je mehr Besucher deines Blogs durch Google kommen, desto höher ist dein Anteil als Besuchern mit dem IE.
    IE-User sind nämlich nicht nur zu dumm einen vernünftigen Browser zu benutzen, sie können auch Google nicht bedienen und landen deswegen oft auf Webseiten die mit dem eigentlich gesuchten nichts zu tun haben.


  10. (10) Kommentar by Chikatze @ 12. November 2007, 11:26 Uhr

    @Silent: heheeeeee! :))
    das sind dann aber auch nicht die besucher, die ich auf meinem blog halten möchte! 😉


  11. (11) Kommentar by Silent @ 12. November 2007, 15:03 Uhr

    Eben, daher auch keine Mühe für sie 😉


  12. (12) Kommentar by el-flojo @ 12. November 2007, 21:47 Uhr

    Hey Jens, das hier könnte doch was für dich sein. Ein Plugin, das eine Nachricht für IE-Nutzer anzeigt. Text kannste wohl auch ändern…
    http://www.red-root.com/wordpress/wp-plugin-get-firefox-banner/


  13. (13) Kommentar by Silent @ 15. November 2007, 20:39 Uhr

    Uebrigens, mit dem iPod funktioniert hier alles bestens


  14. (14) Kommentar by Jens @ 17. November 2007, 12:17 Uhr

    @Silent:
    Stimmt natürlich auch. Ich kann auch die Leute verstehen, die sagen, dass sie nicht wg. irgendwelcher Pixelungenauigkeiten beim MS IE optimieren wollen. Wenn es jedoch unleserlich ist weil z.B. Grafiken den Text überlappen, dann finde ich das schon sch….lecht. Oder wie aktuell bei Opera, das man gar nix sieht. :(

    @el-flojo:
    Ich hab so ’nen Plugin inzwischen in Betrieb, dass bei Windows-Nutzern ohne Firefox angezeigt wird.

    @Silent:
    Hehe, das freut mich, aber wundert mich auch nicht – weil Safari ja auch klappt.


  15. (15) Kommentar by Silent @ 17. November 2007, 12:25 Uhr

    Opera funktioniert doch einwandfrei.
    Damit bin ich gerade hier.
    Version 9.24


  16. (16) Kommentar by Jens @ 17. November 2007, 12:27 Uhr

    @Silent:
    mkorsakov berichtet (s.o.), dass es mit 9.24 nicht geht, wenn man auf eine einzelne Beitragsseite geht. Ich kann es momentan hier nicht nachvollziehen, da ich hier kein Opera habe.


  17. (17) Kommentar by Silent @ 17. November 2007, 12:41 Uhr

    Hab dir einen Screenshot zugeschickt.
    Die Darstellung ist einwandfrei und alles in der Navileiste Links und Rechts funktioniert auch ohne Probleme


  18. (18) Kommentar by Jens @ 18. November 2007, 17:24 Uhr

    @Silent:
    (wie an sich schon geklärt)

    Leider nicht bei einzelnen Beitragsseiten. :(


Schreib einen Kommentar

Line and paragraph breaks automatic, e-mail address never displayed, HTML allowed: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Mit dem Absenden eines Kommentars wird akzeptiert, dass der angegebene Name, die eMail-Adresse und die derzeit aktuelle IP-Adresse Ihres Internetanschlusses zusammen mit dem Kommentar gespeichert wird. Weiteres hierzu in den entsprechenden Datenschutzhinweisen.